Messing with FileVault

I know I have your attention. Well, I’ve been doing just that, because I’m using macOS Catalina in my old (but working!) MacBook Aluminum Unibody.

This is not a supported configuration, so I’m not on the safe side here…

I installed that unsupported version thanks to the macOS Catalina Patcher tool by dosdude1. It just works fine, beside having some trouble bringing and installing latest OTA updates. For that task, I’ve been {using|messing with} CatalinaOTAswufix, from the awesome jackluke.

As much as I like both tools, it looks like you can’t get everything working at the same time in certain circumstances. That’s life.

I was having a working configuration until some minutes ago: macOS Catalina 19H15 working in a MacBook from 2008. I wanted to enable FileVault as I had with Mojave. After encryption, rebooted, and the computer hung up. How am I going to fix this? I can’t login to the computer anymore.

Google came to help me. I found this great article about how to do FileVault tasks command-line in Mojave, that also applies here. Then:

  • I booted from my patched Catalina installation USB media in Rescue Mode.
  • Mounted the encrypted volume through Disk Utility
  • Open a Terminal and followed the directions to decrypt the vaulted volumes.

One funny thing: Once you do that to the first of the two encrypted volumes, there’s some sort of link between them (system and data volumes), and they start decrypting at the same time.

Once the decryption process finished, I reinstalled the working patched version 19H15 of macOS Catalina and rebooted the computer. And off you go!